[t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik halla

Wszystko o silniku, jego osprzęcie, ukł. wydechowym...
essi79
Nowicjusz
Nowicjusz
Posty: 3
Rejestracja: 09 kwie 2009, 16:05
Lokalizacja: warszawa

[t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik halla

Post autor: essi79 »

Witam wszystkich forumowiczów!
Jestem szczęśliwym posiadaczem Toyoty Avensis 1.6 1999r 4AFE
Od jakiegoś czasu gdy przekraczam 4500 obrotów pojawia mi się kontrolka "check engine". Jak odpuszczam gaz kontrolka gaśnie. Gdy podłączyłem Toyotkę pod komputer wyświetla mi błąd: "czujnik położenia wałka rozrządu - usterka". Jak wielkie było moje zdziwienie jak dowiedziałem się, że taki czujnik kosztuje 500 zł w ASO. Jeszcze większe zdziwienie ogarnęło mnie gdy Pan z ASO po podaniu mu numeru nadwozia stwierdził, że w mojej Toyotce takiego czujnika nie ma :wow:
Identyczna sytuacja jest gdy szukam tego czujnika na stronie www.toyodiy.com. Według schematu powinien znajdować się gdzieś koł aparatu zapłonowego ale nie mogę go tam namierzyć. Obawiam się, że będę musiał wymienić cały aparat zapłonowy.
Czy ktoś spotkał się z taką sytuacją? Będę wdzięczny za wszelkie wskazówki prowadzące do rozwiązania tej zagadki.
Pozdrawiam
Ostatnio zmieniony 21 cze 2010, 21:29 przez essi79, łącznie zmieniany 1 raz.

Awatar użytkownika
wrc
Moderator
Moderator
Posty: 17094
Rejestracja: 16 lis 2007, 07:12
Model: Avensis T22
Lokalizacja: Schwäbisch Hall

Post autor: wrc »

temat o takim czujniku w aparacie jak przez mgle kojarze, poszukaj dobrze na forum :cfaniak:

pozdr :-D

a.kopcinski
Nowicjusz
Nowicjusz
Posty: 7
Rejestracja: 07 lis 2008, 10:11
Lokalizacja: MIńsk Maz

Post autor: a.kopcinski »

Czujnik znajduje sie w środku aparatu zapłonu, ja własnie zamierzam wymienić bo też mi sie pali lampka check engine, czujnik Halla kupilem za 175zł. Aparat jest firmy BOSH

essi79
Nowicjusz
Nowicjusz
Posty: 3
Rejestracja: 09 kwie 2009, 16:05
Lokalizacja: warszawa

Post autor: essi79 »

Dzisiaj wymieniłem kopułkę i palec, ale niestety przy 5000 obrotów znów zapalił się check. Możesz dać namiary na ten czujnik - jakiś symbol, ewentualnie gdzie go mogę kupić? Słyszałem opinie, że jeżeli czujnik jest zintegrowany z aparatem to nie można go wymienić oddzielnie tylko razem z aparatem.

[ Dodano: 2009-05-14, 22:34 ]
Znalazłem czujnik halla do aparatu BOSCH. Jego numer katalogowy to 1237031296. Czy to jest ten czujnik?

[ Dodano: 2009-05-19, 20:26 ]
Dzisiaj wymieniłem czujnik położenia wałka rozrządu w aparacie zapłonowym i ... nadal wyświetla mi się błąd "czujnik położenia wałka rozrządu - usterka". Dodam, że czujnik wymieniony na nowy firmy BOSCH. Czy ktoś może ma jakieś pomysły co mógłbym jeszcze zrobić???

[ Dodano: 2009-05-20, 12:34 ]
Panowie, czy naprawde nikt się nie spotkał z podobną sytuacją???
Jestem już zdesperowany. Wymieniłem wszystko w aparacie zapłonowym i nadal zapala mi się check engine przy wysokich obrotach. Najgorsze jest to, że jak silnik się nagrzeje to lampka zapala mi się już przy 3200 obrotów i szarpie samochodem. Czy cewka może mieć na to wpływ??

suchy_lub
Stara się...
Stara się...
Posty: 58
Rejestracja: 04 paź 2010, 21:56
Model: T25 FL
Lokalizacja: Lublin

Re: [t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik ha

Post autor: suchy_lub »

Witam,

Podłączę się pod temat.
Mam problem z czujnikiem położenia wałka rozrządu. Chciałbym go wymienić, jest tylko jeden problem.
Posiadam aparat zapłonowy Bosch 19100-02020 jest chyba jakiś nietypowy ponieważ wtyczka do czujnika posiada 3 piny (zazwyczaj występuje 4).
Nie mogę nigdzie znaleźć używki. Numer czujnika to 12 30 329 038.

Czy ktoś może wie od jakiego innego samochodu pasuje cały aparat lub sam czujnik?

Awatar użytkownika
maco
Coś wie...
Coś wie...
Posty: 400
Rejestracja: 27 mar 2008, 14:34
Model: Avensis T22 FL
Lokalizacja: Zamość

Re: [t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik ha

Post autor: maco »

Po pierwsze trzeba by sprawdzić czy wiązka przewodów nie jest gdzieś uszkodzona i sprawdzić rezystancję pomiędzy wtyczką czujnika a złączem sterownika. Samochód jeździ normalnie? Niema żadnych niepokojących symptomów? Kiedy ta kontrolka zaczęła się pokazywać? Nie było to po jakimś wydarzeniu drogowym lub remoncie samochodu? Przydała by się diagnoza równoległa sygnału z czujnika.
Obrazek Zegary mojego autorstwa:-) http://avensis.info/viewtopic.php?f=5&t=9502
Oświetlenie otoczenia samochodu http://avensis.info/viewtopic.php?f=5&t=10309 ____________________________________________________________________________________________Pomogłem? kliknij PLUSA :ok:

suchy_lub
Stara się...
Stara się...
Posty: 58
Rejestracja: 04 paź 2010, 21:56
Model: T25 FL
Lokalizacja: Lublin

Re: [t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik ha

Post autor: suchy_lub »

maco pisze:Po pierwsze trzeba by sprawdzić czy wiązka przewodów nie jest gdzieś uszkodzona i sprawdzić rezystancję pomiędzy wtyczką czujnika a złączem sterownika. Samochód jeździ normalnie? Niema żadnych niepokojących symptomów? Kiedy ta kontrolka zaczęła się pokazywać? Nie było to po jakimś wydarzeniu drogowym lub remoncie samochodu? Przydała by się diagnoza równoległa sygnału z czujnika.
Lampka się zaświciła poprostu kiedyś podczas jazdy. Zapalała się czasem na dłużej czasem krócej. Teraz potrafi zgasnąć bądź zapalić się po wjechaniu w dziurę. Ewidentnie cos nie łączy.
Rozebrałem i rozkułem aparat zapłonowy faktycznie jeden przewód był przetarty. Wszystko poizolowałem termozłączkami (lepiej niż fabrycznie).
Po złożeniu, czujnik dalej się świeci.

W środku nie było widac aby któryś przewód był uszkodzony.

Samochód jeździ normalnie, słychać tylko cykanie wtrysków (chodzi w trybie awaryjnym) pozatym zero objawów (nie ma nawet spadku mocy).

Czy można jeździć jeśli silnik chodzi w trybie awaryjnym?

Awatar użytkownika
wrc
Moderator
Moderator
Posty: 17094
Rejestracja: 16 lis 2007, 07:12
Model: Avensis T22
Lokalizacja: Schwäbisch Hall

[t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik halla

Post autor: wrc »

suchy_lub pisze:Czy można jeździć jeśli silnik chodzi w trybie awaryjnym?
jak trzeba to można, ale bez wiedzy co jest lepiej się nigdzie nie wybierać

Awatar użytkownika
maco
Coś wie...
Coś wie...
Posty: 400
Rejestracja: 27 mar 2008, 14:34
Model: Avensis T22 FL
Lokalizacja: Zamość

Re: [t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik ha

Post autor: maco »

a kiedy miałeś wymieniany rozrząd? może tak się robić jeśli masz słabe napięcie paska rozrządu.
Obrazek Zegary mojego autorstwa:-) http://avensis.info/viewtopic.php?f=5&t=9502
Oświetlenie otoczenia samochodu http://avensis.info/viewtopic.php?f=5&t=10309 ____________________________________________________________________________________________Pomogłem? kliknij PLUSA :ok:

pejter
Stara się...
Stara się...
Posty: 70
Rejestracja: 13 maja 2007, 22:30
Model: Avensis T25
Lokalizacja: Konin

Re: [t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik ha

Post autor: pejter »

maco pisze:Po pierwsze trzeba by sprawdzić czy wiązka przewodów nie jest gdzieś uszkodzona i sprawdzić rezystancję pomiędzy wtyczką czujnika a złączem sterownika.
Maco, jak sprawdzić pomiędzy czujnikiem a sterownikiem, bo też mam z tym czujnikiem problem i podobny problem co Suchy. Check engine zapala i gaśnie, wychodzi mi kod 12 (czyli ten czujnik) i kod 53 (spalanie stukowe). Czasem poszarpie no i cykaja wtryski w trybie awarayjnym. Jeżdzę już tak od roku i irytuje mnie już ta świeciąca lampka i szarpanie obrotami na luzie.
Pozdrawiam
Piotr

suchy_lub
Stara się...
Stara się...
Posty: 58
Rejestracja: 04 paź 2010, 21:56
Model: T25 FL
Lokalizacja: Lublin

Re: [t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik ha

Post autor: suchy_lub »

maco pisze:a kiedy miałeś wymieniany rozrząd? może tak się robić jeśli masz słabe napięcie paska rozrządu.
U mnie rorząd był wymieniany jakieś 70 tys km temu.
Trochę mi się niechce wierzyć że tam leży problem.

Do niedawna u mnie pomagało odłączenie i podłączenie wtyczki od czujnika, na uruchomionym silniku. Wtedy lampka znikała a wtryski odrazu zaczynały chodzić cicho.

Jest również tak że czasem na dołku potrafiła lampka zgasnąć.

pejter czy również masz aparat Boscha 19100-02020?

Awatar użytkownika
maco
Coś wie...
Coś wie...
Posty: 400
Rejestracja: 27 mar 2008, 14:34
Model: Avensis T22 FL
Lokalizacja: Zamość

Re: [t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik ha

Post autor: maco »

moim zadaniem to jakiś problem w wiązce przewodów ale jeśli zajmował się już tym mechanik to pewnie powinien to sprawdzić. Popytam jeszcze kogoś kto się zna jaki może być powód i powiem co się dowiedziałem. Wtyczka na tym czujniku dobrze łączy? nie są styki zaśniedziałe?
Obrazek Zegary mojego autorstwa:-) http://avensis.info/viewtopic.php?f=5&t=9502
Oświetlenie otoczenia samochodu http://avensis.info/viewtopic.php?f=5&t=10309 ____________________________________________________________________________________________Pomogłem? kliknij PLUSA :ok:

pejter
Stara się...
Stara się...
Posty: 70
Rejestracja: 13 maja 2007, 22:30
Model: Avensis T25
Lokalizacja: Konin

Re: [t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik ha

Post autor: pejter »

suchy_lub pisze:pejter czy również masz aparat Boscha 19100-02020?
Tak, też ten z czerwoną kopułką. U mnie już od roku wyświetla się check i na początku zapał się i znikał, a teraz praktycznie cały czas się świeci, czasem na chwilę zgaśnie, wtryski chodzą podwójnie i szarpie na wolnych obrotach. Czy jest możliwe, że któryś z tych kabelków w czujniku się przytarł albo coś, bo jak poruszałem ostatnio tą kostką z wpiętym kablem, przed jeden dzień się przestało świecić, dopiero na następny dzień się zaświeciło ponownie.
Pozdrawiam
Piotr

Awatar użytkownika
maco
Coś wie...
Coś wie...
Posty: 400
Rejestracja: 27 mar 2008, 14:34
Model: Avensis T22 FL
Lokalizacja: Zamość

Re: [t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik ha

Post autor: maco »

trzeba wziąć schemat instalacji, miernik i mierzyć po kolei rezystancję przewodów i czy nie są gdzieś zwarte do masy. to że pomogło ruszanie kablami świadczy że przyczyna tkwi w nich. tak mi się wydaje przynajmniej ;-)
Obrazek Zegary mojego autorstwa:-) http://avensis.info/viewtopic.php?f=5&t=9502
Oświetlenie otoczenia samochodu http://avensis.info/viewtopic.php?f=5&t=10309 ____________________________________________________________________________________________Pomogłem? kliknij PLUSA :ok:

piotr_ka
Stara się...
Stara się...
Posty: 60
Rejestracja: 27 kwie 2011, 13:45
Model: Avensis T22
Lokalizacja: Warszawa

Re: [t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik ha

Post autor: piotr_ka »

czujnik Halla sprawdza się w prosty sposób nawet w domu. Przerabiałem ten temat na swoim Bosch'owskim aparacie.'
Podpinasz pod kostkę zasilanie stałe 12V ( ja użyłem małego zasilacza od laptopa) a miernikiem mierzysz pomiędzy zaciskami "+" a "0" czy woltomierz pokazuje wychylenie zakres powyżej 12 V ustawiony na mierniku. zdejmij kopułkę i obserwuj jak będziesz kręcić, czy w momencie,jak masz przerwę na metalowej wew. kopułce osłaniającej czujnik Halla, powinien być impuls.... ale jeden "mechanik", jak mu powiedziałem że to sprawdziłem na Voltomierzu to stwierdził że powinno się sprawdzać na oscyloskopie ??? nie mam pojęcie do końca co on by chciał\ na tym zobaczyć. zresztą w różnych postach i opisach nikt nie pisał o oscyloskopie.... ALE czujnik Halla jest tak tani że można go wymienić jak uda ci się rozebrać aparat. Aaa po rozebraniu na części pierwsze, proszę zwrócić uwagę na podkłądki kompozytowe, bo moje były uszkodzone i wytarte przez co wydostawał się olej na zew. Sporo pisałem postów na temat tych specjalnych podkładek ( specjalne bo odporne na temp min. 200*C i odporne na ścieranie) kilka osób proponowało mi pog=dkladki od instalacji wodnej ale uważam ze to nie to samo, że nie są tak odporne na ścieranie.
Znalazłem firmę na ul. Łopuszańskiej w Wawie która wytoczyła mi je na wymiar z jakiegoś tworzywa.

Co do rozbiórki aparatu na części pierwsze (odnośnie Boscha). Nit który jest wbity w oś najlepiej wybija się kluczem ampulowym. Po odcięciu krótszej jego części mamy SUPER twardy wybijak który nam się nie skrzywi. Ja poświęciłem ampul o rozm. 3mm Proszę pamiętać by nic nei ostrzyć bo rozbijecie nit i będzie zaklinowane. Do tej pracy najwygodniej w 2 osoby.

Awatar użytkownika
maco
Coś wie...
Coś wie...
Posty: 400
Rejestracja: 27 mar 2008, 14:34
Model: Avensis T22 FL
Lokalizacja: Zamość

Re: [t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik ha

Post autor: maco »

Mechanik miał rację...fachowo powinno się sprawdzać oscyloskopem. Tylko kto w domu ma oscyloskop ;-)
Obrazek Zegary mojego autorstwa:-) http://avensis.info/viewtopic.php?f=5&t=9502
Oświetlenie otoczenia samochodu http://avensis.info/viewtopic.php?f=5&t=10309 ____________________________________________________________________________________________Pomogłem? kliknij PLUSA :ok:

piotr_ka
Stara się...
Stara się...
Posty: 60
Rejestracja: 27 kwie 2011, 13:45
Model: Avensis T22
Lokalizacja: Warszawa

Re: [t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik ha

Post autor: piotr_ka »

acha.... ale myślę że taniej niż oscyloskop będzie zakup nowego czujnika.... i pewniejszy, bo obsługaiwać się tym też trzeba umieć. :tak:

pejter
Stara się...
Stara się...
Posty: 70
Rejestracja: 13 maja 2007, 22:30
Model: Avensis T25
Lokalizacja: Konin

Re: [t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik ha

Post autor: pejter »

No i teraz jestem w kropce... chciałem już jechać do Bosch service żeby zamówić czujnik wałka do aparatu boscha. Ale jeszcze wpadłem na pomysł, jak sprawdzić czy dochodzi do niego zasilanie i czy on daje sygnał. A więc na kabel na + i - podpiąłem żaróweczke i przekręciłem zapłon - żarówka świeci czyli jest OK, poruszam kablami dalej świeci więc stwierdziłem że kabel dobry. Wpiałem kostkę w czujnik ponownie i tym razem wpiąłem się zarówką w przewody + i 0. Spodziewałem się, że skoro czujnik jest walnięty żarówka nie będzie się zapalać. Ale okazało się, że zarówka mruga równo co obrót wałka, im większe obroty tym szybsze mruganie, czyli wychodzi na to że czujnik sprawny. W takim razie co jest nie tak z tym sterowaniem, co jeszcze siedzi na błędzie 12 i 53?
Pozdrawiam
Piotr

Awatar użytkownika
maco
Coś wie...
Coś wie...
Posty: 400
Rejestracja: 27 mar 2008, 14:34
Model: Avensis T22 FL
Lokalizacja: Zamość

Re: [t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik ha

Post autor: maco »

to że żarówka mruga nie oznacza w stu procentach że czujnik jest dobry. Należało by sprawdzić czy przewód sygnałowy idący do sterownika nie jest uszkodzony. Nie może mieć rezystancji większej niż 0,5ohm
Obrazek Zegary mojego autorstwa:-) http://avensis.info/viewtopic.php?f=5&t=9502
Oświetlenie otoczenia samochodu http://avensis.info/viewtopic.php?f=5&t=10309 ____________________________________________________________________________________________Pomogłem? kliknij PLUSA :ok:

piotr_ka
Stara się...
Stara się...
Posty: 60
Rejestracja: 27 kwie 2011, 13:45
Model: Avensis T22
Lokalizacja: Warszawa

Re: [t22] 4AFE: Czujnik położenia wałka rozrządu, czujnik ha

Post autor: piotr_ka »

Pejter... tak jak pisał kolega wyżej. nie zawsze domowy sposób sprawdzania czujnika Halla ( prawidłowa nazwa) za pomocą żarówki czy miernika. potrzeba do tego oscyloskopu, tak mi powiedział mechanik. taki czujnik jest tani mozesz kupic w InterCars bez problemów lub w sklepie Nippon. koszt nie drogi wiec mozna wymienić, odnośnie rozbiórki aparatu zapłoniowego, pisałem w którymś poscie, więc szukaj ich po moim nicku, bo rozebranie nie jest proste. Szoda że nie jesteś z Wawy bo mógłbym z chęcią ci pomóc. Jeśłi chodzi o cały aparat to ciężko go dostać. Masz taki sam silnik co ja. Ciężko dostać nowe a jak są to po okolo 1000 zeta a w ASO to nawet po 2400. Pytałem znajomych w samym Boschu to tego typu aparatu już nie produkują. Można szukać na magazynie Boscha w niemczech czy jakieś "resztki" się ostały.

ODPOWIEDZ